Not Happy with the wildcat 1000 x
Page 1 of 6 1 2 3 ... LastLast
Results 1 to 15 of 85
Like Tree39Likes

Thread: Not Happy with the wildcat 1000 x

  1. #1
    Member
    Join Date
    Nov 2016
    Location
    illinois
    Posts
    30
    Member #
    17378
    Liked
    10 times

    Not Happy with the wildcat 1000 x

    Been getting the run around just wonder If anyone else has the same problems?My wildcat x 1000 is about 45 days old and has had this problem from day 1.Start it up run for 45 minutes or so get it good and warm and shut it off for 5-10 minutes take off and it will start misfiring spit and sputter after about 5-10 minutes into ride then let off throttle and floor it and it clears up until next time.Dealer is giving me the run around and not getting any results yet from Artic Cat.Dealer tells me If I want it to perform correctly I have to buy a high performance ECU at my expense and will void my warranty.They have tried a ECU from a new machine (no change)checked fuel psi checked injectors checked spark plugs found no problems.Arctic Cat does not have a fix they said to run in low range lol Still does it and dealer trying to say that's the machines nature.Not happy with that after I have purchased 4 machines from them and several thousand in extended warranty and accesories in the last year.A lot of other dealers told me they are good at selling them but NO SERVICE AFTER THE SALE!!!! Priced a 2016 Yamaha from a different dealer that I have never done business with and they were almost 4500.00 cheaper than the dealer I have been spending my money with this past year.Dealer also told me that all Arctic Cat 1000 x do this so I guess buyer beware

  2. #2
    Member
    Join Date
    Oct 2016
    Posts
    43
    Member #
    16138
    Liked
    10 times
    Sorry to hear about the trouble, I am no Arctic cat Expert, I have the Only one that I have purchased in mid Oct 2016, Runs fantastic, seems like the dealer comment that all of them run poorly is out of line. Hope you get some resolve on the issue. and yes I would be pissed with that situation.

  3. #3
    Supporting Member
    Join Date
    May 2012
    Location
    In the eNVy
    Posts
    403
    Member #
    1342
    Liked
    278 times
    Wildcat X's are naturally cold blooded but not that cold blooded. Typically on a cold start they will sputter for a minute or two and then be good to go, after that all starts should be easy during a ride. Things that come to mind are fuel choice, maybe a sticky injector, plugs, poor connection from the stator/cps wires and timing.

    ECU has nothing to do with it, aftermarket flash would probably make it worse so don't fall into that.

    First thing if do is let it sputter and run for a bit and then inspect the plugs, see if one of the cylinders is pig rich.
    WOTM May 2016 - Per Hollywood's instructions

  4. Remove Advertisements
    WildcatForums.net
    Advertisements
     

  5. #4
    Supporting Member
    Join Date
    May 2012
    Location
    In the eNVy
    Posts
    403
    Member #
    1342
    Liked
    278 times
    Oh and add valve adjustment to that list.
    WOTM May 2016 - Per Hollywood's instructions

  6. #5
    Senior Member
    Join Date
    Jun 2016
    Posts
    443
    Member #
    11514
    Liked
    304 times
    Call AC yourself do not rely on the dealer... Seems to me that they just want to make more money off of you... When you do call them and if you do not get anywhere with whom ever you talk to then call them back 1hr or 2 and you should get someone else that may do something for you... Make sure you get their name... Talk to them with respect and you will go further with them... Just saying
    Bigdaddy12 likes this.

  7. #6
    Member
    Join Date
    Nov 2016
    Location
    illinois
    Posts
    30
    Member #
    17378
    Liked
    10 times
    I run 92 octane in it,and I have checked the plugs after it has its mis firing issue,havent checked the valve clearance yet didn't think that would be issue with it being problem from day 1 its just got me baffeled I have called Arctic Cat and seem to get different story from different people each time.Dealer says they have inspected fuel system but idk at this point not sure what to think.Just very frustrating to spend 18,000 on a machine that sits in the shop and all the dealer wants to do is sell me more parts.

  8. #7
    Junior Member
    Join Date
    Nov 2016
    Posts
    15
    Member #
    17114
    Liked
    10 times
    Just picked up my 2016 it has none of those issues, but i have had quads that require at least 91 octane to run and they do almost exactly the same thing if you don't run 91 or higher in it.
    izom likes this.

  9. #8
    Senior Member
    Join Date
    Jan 2016
    Location
    East, Tn.
    Posts
    1,158
    Member #
    6810
    Liked
    712 times
    I had a similar issue with my 15 model and it wasn't long and the fuel pump completely quit my dealer put a new fuel pump in it and the issue went away. Also when you start it the second time do you turn the switch on and wait till the fuel pump stops (builds fuel pressure) before you start it?
    blast likes this.
    2015 Wildcat x Limited
    AC stereo roof
    Poly windshield
    Poly rear window
    Trail
    Armor full skids with nerf sliders
    Factory UTV A arm skids

    High Lifter high clearance lower radius bars
    32" curved duel row led light bar with custom mount
    AJ's front fender flares and shoulder guards
    AC rear fender flares
    2' Outlaw whips
    Seizmik center and side mirrors

    My YouTube channel
    https://www.youtube.com/channel/UCcc...vt6vTNxK88WoWA

  10. #9
    Senior Member
    Join Date
    Nov 2015
    Location
    landofarnolds.
    Posts
    457
    Member #
    5717
    Liked
    371 times
    NO SERVICE AFTER THE SALE
    ..looks like this- so-

    and "all Arctic Cat 1000 x do this" just bulsh.t

    CMON- go and find a good mechanic/another AC dealer !! :- () its a simple motor with an simple FI/ECU- its not an overengenieered toyota prius wit 30 computers and 150 sensors...
    Last edited by izom; 11-23-2016 at 02:28 AM.
    Get.Slicked likes this.
    wildcat 1000 limited 2013,5

  11. #10
    Senior Member
    Join Date
    Apr 2014
    Posts
    1,231
    Member #
    3330
    Liked
    345 times
    wouldnt hurt to check the fuel pump for presure, find a new dealer sounds like that one not on the up & up.
    Bigdaddy12 likes this.

  12. #11
    Senior Member
    Join Date
    Feb 2013
    Posts
    1,772
    Member #
    2050
    Liked
    751 times
    Where are you located and maybe we can help you get into a better dealer?
    Sand-n-Sea likes this.
    February 2016 Wildcat of the Month

  13. #12
    Supporting Member
    Supporting Member

    Join Date
    Jun 2015
    Location
    LaFayette, GA
    Posts
    552
    Member #
    5196
    Liked
    216 times
    Exact same problem on my 15X from new. Was told by dealers and forum members it was likely bad plugs. New plugs did not help but it did finally stop doing it after about 500+ miles; at least I don't remember it occurring on the past several rides. Never did figure it out but all is fine now. Sounded exactly like a carburetor motor vapor locking.

    Rick S.
    August 2016 Wildcat of the Month

    15 X1000 - White; AC: Hard Top Roof, Split Flip-Up Windshield, UHMWPE Skid Plate with Rocker & A-Arm Guards, Overhead Bag, Rear Receiver; Pace: 12mm Stud Kit; UTVinc: Harness Bar, 4point 3" Harnesses, Parking Brake; American Star: Tie Rods; High Lifter: Max Clearance Lower Radius Rods; ATV-Tek: Clearview Rear-view Mirror; Seizmik: Pursuit mirrors; Penton: 180w 34" LED Light Bar, Side lights, Rear Flood; KFI: Winch Mount & Bumper; SuperATV: 4,500 lb Winch w synthetic rope; STI: HD5 14x7 Beadlock Wheels w 1 1/2" rear spacers; DiscountTireDirect: Rage Thunder 30x10R-14 Tires ; Dalton Industries: Clutch Kit; Concoursgreg: 12 Fused Circuits w 6 relays waterproof fuse panel; AJ's: Fender Flares, Rear Window, Bushing Kit & Shoulder Shields; Drake: Fire Extinguisher Mount; Ram Mount: Tablet & GoPro Mount; Wolfsnout: Mask; MLS: Bad Dawg Box, Steering Up, AC Full Doors; Tribal Whips: Tandem 3' Aurora Lighted Whips; XTreme: Lift Kit; Odyssey: Aux Battery.

  14. #13
    Senior Member
    Join Date
    Mar 2012
    Location
    SW Wyoming
    Posts
    407
    Member #
    1196
    Liked
    225 times
    Quote Originally Posted by RickSinGA View Post
    Exact same problem on my 15X from new. Was told by dealers and forum members it was likely bad plugs. New plugs did not help but it did finally stop doing it after about 500+ miles; at least I don't remember it occurring on the past several rides. Never did figure it out but all is fine now. Sounded exactly like a carburetor motor vapor locking.

    Rick S.
    Spark plugs, all day. These things hate short run, bad startup habits. The Idle Speed Control circuit, is adaptive, so it learns the operating habit of the engine and throttle body range, so to keep it on the good side,
    -Cycle the key,
    -Let the fuel pump run until it stops,
    -Start the engine with the intention of letting it run until the cooling fans cycle, before shutting off.

    One thing with the CPR8E spark plugs, fuel fouling a spark plug makes it unreliable, from then on. -Do yourself a favor and install a set of CR7EIX Iridium plugs - they're the last plugs you will most likely buy.
    RBerry likes this.

  15. #14
    Supporting Vendor
    Supporting Member

    Join Date
    Jul 2012
    Location
    Georgetown, KY
    Posts
    1,332
    Member #
    1532
    Liked
    1107 times
    Where are you located?
    Bigdaddy12 likes this.
    MLS Powersports llc
    502-863-0920
    www.mlspowersports.com
    http://www.awesomeoffroad.com
    "The Wildcat Capital of the World"

  16. #15
    Senior Member
    Join Date
    Mar 2012
    Location
    NW Colo
    Posts
    4,980
    Member #
    1128
    Liked
    2370 times
    Quote Originally Posted by Get.Slicked View Post
    One thing with the CPR8E spark plugs, fuel fouling a spark plug makes it unreliable, from then on. -Do yourself a favor and install a set of CR7EIX Iridium plugs - they're the last plugs you will most likely buy.

    Are the CR7EIX the same length & heat range as the CPR8E? The last time I checked (few years back) they did not have a replacement for them yet with the Iridium's..

    OP have you checked your gas tank for a build up in pressure when this happens? Just open the cap and see if their is any pressure, perhaps a defective vent valve..
    blast likes this.
    2012 Black Cat / 2013 Red Ltd. - Same mods on both machines

    4 Channel Wireless Steering Wheel Buttons (Post 27)

    Dual Bats w / Smart Relay, Custom Bumpers w/ Warn RT40 winch /RR 660 Intercom / Yaesu 75W Radio/ Steering Mod / Cat Eyes
    Lowrance Elite 7m Chart-Plotter Mtd In Dash / Gauge Mtd On Steering Column / Pro Armor Doors / 12 MM Studs / 3" 5 Pts

    The Shiny Keg Plazma Kutter

    Went To Market: 2011 CowMander


 
Page 1 of 6 1 2 3 ... LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Totally happy with wild cat 1000 2014 x at glamis sand dunes
    By doghouse in forum Wildcat General Discussion
    Replies: 19
    Last Post: 10-20-2015, 08:34 AM
  2. Replies: 12
    Last Post: 12-12-2014, 08:44 PM
  3. Not happy with my wildcat right now
    By localfiremedic in forum Wildcat General Discussion
    Replies: 44
    Last Post: 04-15-2014, 04:54 PM
  4. Happy birthday my wildcat turns 1!
    By Rocket ron in forum Wildcat General Discussion
    Replies: 0
    Last Post: 10-09-2013, 09:13 PM

Search tags for this page

forum wildcat 1000 dunes

Click on a term to search for related topics.
Powered by vBulletin® Version 4.2.3
Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO ©2011, Crawlability, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
All times are GMT -6. The time now is 10:24 AM.