2013.5 wildcat 4 running rough.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jul 2018
    Location
    Kerman, CA
    Posts
    2
    Member #
    29523

    2013.5 wildcat 4 running rough.

    Hey guys. New to site and first post. I have a 2013.5 wildcat 4 with low hours on it. Last weekend in the desert after a hill climb my wildcat started running rough and then had no power. Came to a stop and it quit. Had to get towed back to camp. Once home i was able to get it to start but only if i let the fuel pump cycle 8 times. If i can get it to start, it runs really rough and will not go above 2700 RPM's. It will only run for a short while. No codes are being set. Has anyone experienced this before? Any Ideas?

  2. #2
    Senior Member
    Join Date
    Aug 2017
    Location
    Newport, WA
    Posts
    1,024
    Member #
    23514
    Liked
    457 times
    I'm thinking you have a fuel pressure problem. The humming that I hear for a few seconds right after turning on the ignition is from the idle control valve on my '15 X, not the fuel pump, so hearing a hum and then silence does not mean the fuel pump has developed proper pressure.

    You can get at the fuel pump by removing the radiator cover and the cargo tray.
    2015 Wildcat 1000X Ltd, Textron rear axle upgrade, Alba slotted brake rotors (front diameter on all 4), flip-up windshield, soft rear window, PRP seats, custom seat mounts with tool storage, 6 pt harnesses, AC spare tire mount, AC step rail/sliders, push-button E-brake, self-cancelling turn signals using rear brake lights, stalk light controls, 4"x7" rearview mirrors, front/rear hitch receivers, receiver mounted winch w/ wireless remote, LED roof light, Rugged intercom & headsets

  3. #3
    Junior Member
    Join Date
    Jul 2018
    Location
    Kerman, CA
    Posts
    2
    Member #
    29523
    I removed the cargo tray and the radiator cover last night. I will start with checking fuel pressure. Thanks.


 

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. running great to,, running like chit
    By on top now what in forum Wildcat X
    Replies: 4
    Last Post: 11-19-2018, 11:10 AM
  2. Rough Idle & not running at 100% help please
    By MrSandman in forum Wildcat General Discussion
    Replies: 13
    Last Post: 03-07-2017, 10:16 PM
  3. Great rough, flooded trail ride in the Turbo Wildcat !
    By Turbo Dynamics in forum Wildcat Trail / Trail XT
    Replies: 2
    Last Post: 04-21-2014, 08:39 AM
  4. Something sounds like it is running when the cat is not running
    By Meow in forum Wildcat General Discussion
    Replies: 2
    Last Post: 08-06-2012, 12:10 PM
  5. Replies: 1
    Last Post: 06-30-2011, 03:18 PM

Tags for this Thread

Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO ©2011, Crawlability, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
All times are GMT -6. The time now is 04:54 PM.