Clutch Fixes? - Page 2
Page 2 of 2 FirstFirst 1 2
Results 16 to 20 of 20
Like Tree18Likes

Thread: Clutch Fixes?

  1. #16
    Junior Member
    Join Date
    Jan 2017
    Posts
    3
    Member #
    19314
    Liked
    5 times
    Hello All, I have a 2015 trail that only has 83 miles on it and is on it's second clutch that has only 13 miles on it and is sticking!!!! To say I am very unhappy is an understatement!!! I have a very good dealer that replaced my first clutch for me, my machine was no longer covered under warranty when the first started to stick. He is trying to help me with ideas to make the new clutch work, I understand he can't foot the bill for another. I am going to try and remove material any way i can to make this work. I have sent a email to TEAM IND. to see if I get any response from them. Has anyone else contacted TEAM and if so what did they say? I have bought many many Arctic cat machines over the years and this is the only one i was sorry to have bought!! I would sell it when it is fixed if not for the fact i would loose so much money.

  2. #17
    Senior Member
    Join Date
    Jul 2015
    Location
    Ont Canada
    Posts
    960
    Member #
    5315
    Liked
    432 times

  3. #18
    Junior Member
    Join Date
    Oct 2019
    Location
    no alabama
    Posts
    13
    Member #
    31895
    Liked
    5 times
    Quote Originally Posted by kentuckywild View Post
    Has anyone else contacted TEAM and if so what did they say?
    not TEAM, but teams new aftermarket 'division' Venom...

    they said 'weak spring or swollen buttons'

    since i didn't want to take the spider off... he-al-lacious torque required along with he-at to break the loctite i have read... i went with the 'removing a thou or two from the towers' and if was def better. read the summary in my thread....


    chop cat

  4. Remove Advertisements
    WildcatForums.net
    Advertisements
     

  5. #19
    Junior Member
    Join Date
    Jan 2017
    Posts
    3
    Member #
    19314
    Liked
    5 times
    Just a little update, I sanded the towers that the buttons slid up and down on. I got the clutch working free. I have not reinstalled it yet to see if it is going to work. I may get it back together this week and will try to run it soon to see if i removed enough. i will post again after i have run it.

  6. #20
    Junior Member
    Join Date
    Jan 2017
    Posts
    3
    Member #
    19314
    Liked
    5 times
    Another update!!! Sad to say but I did get my machine back together but as you can guess from the low miles on my trail (83) I don't ride it much. I have not run it yet to see if I was able to fix my sticking problem. I do however plan on running this thing sometime to see if it is working!!! LOL
    Sak kitty and Justheman80 like this.


 
Page 2 of 2 FirstFirst 1 2

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.3
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO ©2011, Crawlability, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All times are GMT -6. The time now is 02:22 PM.