Wildcat Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have the before mentioned cat where the rev limiter occasionally kicks in, mostly on hard acceleration... Reading in here, most think its the gear position switch or faulty ground... Question, can the shifter being out of adjustment be the issue as there are times when shifting into "H" I have to rise the RPM slightly for it to engage... Just wondering what the group thinks, should I just buy a new switch or ?
Thanks in advance for your advice...
Gotwood,
 

·
Administrator
Joined
·
28,156 Posts
Welcome Gotwood. It shouldn't kick in under hard acceleration unless you've topping out in mph. Are you?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
No, the rev limiter is turning on, it holds a steady RPM when it does... I've read on here where the gear switch thinks it's in reverse and limits the RPM and wanted to ask about it before ordering and replacing...
 

·
Registered
Joined
·
2,661 Posts
IIRC, the gear position sensor is keyed to the shaft on the side of the engine/transaxle. Adjusting the shift cable won't alter that relationship.

Have you ever been able to glance down at the gauge when the RPMs are limited? If you are correct about the gear position sensor, the gauge is probably displaying something other than H or L.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Good call, I checked and it is not moving from H when driving, must be something else turning on the limiter, it will hold it at 4500 RPM but off and on like something is loose like a bad ground or connection... The mystery continues, thank you for your response, very helpful...
 

·
Registered
Joined
·
2,661 Posts
Gear position sensors fail often enough that there are instructions on how to eliminate the sensor by jumpering two wires in the harness. I don't recall how difficult that mod is and if it can easily be done as a temporary test, but you might research it.

A spare used sensor came with my X and I turned it into a plug-n-play jumper that I carried with me, but never needed.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
Gear position sensors fail often enough that there are instructions on how to eliminate the sensor by jumpering two wires in the harness. I don't recall how difficult that mod is and if it can easily be done as a temporary test, but you might research it.

A spare used sensor came with my X and I turned it into a plug-n-play jumper that I carried with me, but never needed.
 

·
Registered
Joined
·
1,411 Posts
it will hold it at 4500 RPM but off and on like something is loose like a bad ground or connection...
dont think its the rev limiter- as its programmed to chime in at 7400 !?? think this sputtering is a fuel (pressure) or wire / sparkplug problem

theres a diagnostic mode and or you can look for fuel pressure!

good luck
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
Thanks, going through the long process of changing spark plugs and while I'm in there, do the valves... No codes were thrown when running so thinking fuel or plugs, or the infamous gear switch... So far the plugs looked good with no fowling noted... Wow, what a pain in the a$$ to get to the plugs...
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top