Wildcat Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
Auto part Tool accessory
Auto part Nut Metal Hardware accessory Household hardware


Motor runs perfect no knocks ticks or anything i took it to the dealer and they havent took a trail motor appart yet

Hope its nothing majour i have no more warenty
 

·
Registered
Joined
·
5,210 Posts
LOL Maybe just an extra part,I had a couple extra parts laying in my skid plate when I bought it.............sure hope that pin wasn't for anything major.....
 

·
Registered
Joined
·
1,840 Posts
Looks like a roller out of a bearing assembly or a lock pin.

Sent from my SM-G920V using Tapatalk
 

·
Registered
Joined
·
1,569 Posts
Is it magnetic? Maybe the magnet off the drain plug?
 

·
Registered
Joined
·
5,210 Posts
Is it magnetic? Maybe the magnet off the drain plug?


Can't remember if there was a pin on my drain plug or not......
 

·
Registered
Joined
·
5,210 Posts
It's fairly simple to look at the parts diagrams online. I picked out all 3 pins that were inside of the engine. The drain plug didn't have a pin.
I just checked the parts diagram,looks like it might be a trip to the shop......
 

·
Administrator
Joined
·
28,096 Posts
Hope for the best, maybe they will cover it. Good luck. Let us know what happens.
 

·
Registered
Joined
·
1,569 Posts
It's fairly simple to look at the parts diagrams online. I picked out all 3 pins that were inside of the engine. The drain plug didn't have a pin.

Yeah I saw that too but the drain plug picture for the 1000 doesn't show a magnet either and I think it has a pin that sticks out. It doesn't stick out that far but it was a possibility.

Out of the three choices you gave I think the oil pump drive gear is the only one that would be that small. There's no way it could fall out so it either fell out during assembly, which would mean no oil pressure, or it is extra.
 

·
Registered
Joined
·
5,404 Posts
At a minimum, make sure the dealer is aware of it and documented it. That way, if something does go bad, they have record of it and may hook you up even though you are out of warranty. That is very scary though.
 

·
Registered
Joined
·
13 Posts
I've been having oil burning issues and I went to drain the oil last night and found the same thing. Did you figure out what this pin goes to? I've been calling around to dealers to figure this out. Unfortunately taking my cat in for warranty repairs is not in the cards for me.

Screw Auto part Fastener Automotive engine part Spark plug
 

·
Registered
Joined
·
6,442 Posts
i remember that happened to someone else about year or so ago. Drock or one of the other early Trail owners. I didnt have this problem but thought it wasnt huge deal....check to see if that pin is magnetic, let dealer see it. Dont see Drock round much these days but then again he could be doing his 6 months of hunting..heh
 

·
Registered
Joined
·
85 Posts
I just changed my oil (initial break in) and found the exact same thing! My engine seems to run fine and it pulls to 70 mph easily.

calling dealer tomorrow morning to have it documented. I still have 3 months warranty left, so we'll see what takes place.

any of the other 2 people in this thread have an update to what happened with their wildcats?

mine is a 2015 sport.
 

Attachments

·
Registered
Joined
·
85 Posts
Yeah I saw that too but the drain plug picture for the 1000 doesn't show a magnet either and I think it has a pin that sticks out. It doesn't stick out that far but it was a possibility.

Out of the three choices you gave I think the oil pump drive gear is the only one that would be that small. There's no way it could fall out so it either fell out during assembly, which would mean no oil pressure, or it is extra.

I agree with the oil pump pin, only one that makes sense as my park function still works fine, and the magneto, as far as I know doesn't mix with oil.

i hope it's extra and I don't have future catistrophic engine failure, if I document it at dealer they should go good if need be next season. My warranty will be up after this winter, and I don't drive it in the winter (use sled) and I only have 150 miles on the thing.
 

·
Registered
Joined
·
5,210 Posts
Lets us know what the dealer says........
 

·
Registered
Joined
·
85 Posts
Dealer had one other case the same as mine and Arctic cat said its nothing to worry about, pin from oil pump that is not needed once engine is assembled. The other case was from early last summer and owner has been driving machine lots with no issues.

pin has no chance getting past screen in oil pan, nothing to worry about. I'm just happy my drain plug magnet picked it up and now it's in the trash.
 

·
Registered
Joined
·
806 Posts
Delete. Wrong thread.
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top