Wildcat Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
I'm hoping someone out there has an answer for this issue. I have done some research and see that there was a recall on year models thru 2017. That's great and all but I have a 2018 Textron wildcat sport 700 xt. It only has 302 miles and 41 hours on it. Tonight I attempted to ride it and it would not go over 15 mph. The first thing I checked was to make sure my seat belt was connected properly. There is no warring lights or codes that the engine is overheating. We checked the air filter and it was clean no gas or oil coming thru there. The engine dose not seem to be getting hot at all!! However after about 10 mins of riding I parked it and the muffler started to glow bright orange and melted my plastic. Engine idles properly but it will not accelerate over 15 mph and again the muffler gets so hot that it melts something every time we ride it. if we just allow it to sit and idle it does not get hot. My husband did add half of a bottle of seafoam to a full tank of fuel not sure if that has anything to do with this issue or not but just some insight. Any ideas will be greatly appreciated. PLEASE HELP !! I am at me wits end with this Textron (ARTIC CAT)!!!!!!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
update: it folded a plug due to the sea foam!! the dealer said this was normal for it to get this hot if that believable. 2 new plugs seems to have fixed ours for anyone who is having this issue as well!!
 

·
Premium Member
Joined
·
1,735 Posts
Sounds like maybe the plug wire was not seated on one of the plugs allowing unburnt fuel to get hot in the exhaust.
 
1 - 3 of 3 Posts
Top