Wildcat Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Thanks for letting me join. We have 16 Sport LTD. have owned almost a year, about 900 miles. On an all day ride, parked for supper and was off for hour and half or so. Got in the Cat, it made it 1/4 mile and coded out- overheat. I've read several posts, talked to some pretty smart people and several dealers. I replaced rad cap, rebuilt water pump, replaced T stat. Went through the whole process of bleeding. Front up, no-spill funnel, bled at water pump and then at T stat housing. Seemed fine. Rode it about 15-20 miles a week ago, was fine. Fan comes on nice- at 204-205, cools down to 185-190 then cycles. Last night I went for a quick ride, let it warm up. Went around block, seemed. Came home, parked it in garage. Started it back up a couple minutes later and temp climbed up and coded out. Tons of air again at T stat housing. What am I missing? I know these heat soak bad, but why is ok and then not ok. Really frustrated.
 

·
Registered
Joined
·
31 Posts
Ok, I'm no expert, but, are you using the right gasket, maybe a thicker one..next, what I have read is these cats need to be run, I warm up my engine, then hammer it, seems to keep everything in check.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Ok, I'm no expert, but, are you using the right gasket, maybe a thicker one..next, what I have read is these cats need to be run, I warm up my engine, then hammer it, seems to keep everything in check.
Hi, not sure what you’re asking about a gasket-
I’m all for running it like you stole it but I’m not sure if this is a drive ability thing or engine. I’ve been a heavy truck and equipment mechanic for over 30 years- this is a pretty basic cooling system.🤷‍♂️🤷‍♂️
 

·
Premium Member
Joined
·
1,822 Posts
I put my nose up about 6”, added coolant to radiator with the bleed screw open engine not running until coolant ran steady. Then burped the bleeder when running . Something to try.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I put my nose up about 6”, added coolant to radiator with the bleed screw open engine not running until coolant ran steady. Then burped the bleeder when running . Something to try.
Did all that friend! Numerous times. Some people are leading me to head/ head gasket😟
 

·
Premium Member
Joined
·
1,822 Posts
Gotcha
 

·
Registered
Joined
·
252 Posts
there is a air bleeder on thereon right sise side of engine dont remember where on cooling sys maybe by thermostat crack it so lightly go for ride .that how fixed mine .hope it not head gaskets.
 

·
Registered
Joined
·
23 Posts
Deffinetly head gasket had a 2012 1000 gt had the same issue once in a while ended up the case ease leaking oil as well so split the case put some good ole silycone haha on it and cleaned up heads and jugs with buff wheel slapped two new gaskets on and never had a problem again make sure no cracks in head and check for warpage with a know great straight edge
 
1 - 8 of 8 Posts
Top