Wildcat Forum banner
1 - 20 of 37 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
I just bought my wildcat on Friday put 18mi on it and there is oil all over the engine I had to put in 1/2 L of oil to get it full drove 2mi back to my truck and the oil was very low again. Has any one else had that problem
 

·
Registered
Joined
·
508 Posts
Wheres it coming from?
 

·
Registered
Joined
·
508 Posts
Well you can go to the trouble of taking it to dealer or try and figure it out yourself. Could be something easy like loose valve cover bolts or something.
 

·
Registered
Joined
·
527 Posts
Don't know what the hold up with mine is. All I get from the service manager is "It's not ready yet, parts are on order". Hopefully yours is a simple fix.
 

·
Registered
Joined
·
329 Posts
The owner of the shop we bought ours from has his own Cat in the shop for a major oil leak. Appears to be coming from the ignition cover on lower drivers side. If you rev the motor up you can see the oil pumping out. Might be a good idea to check this out.

Dwight
 

·
Registered
Joined
·
61 Posts
I too had a oil leak. It was coming from the forward cylinder valve cover. Upon disassembly it was discovered the o-ring had been pinched during assembly. The missing piece was inside the valve train but caused no problems. The o-ring was replaced and no further problems.
 

·
Registered
Joined
·
2,100 Posts
I too had a oil leak. It was coming from the forward cylinder valve cover. Upon disassembly it was discovered the o-ring had been pinched during assembly. The missing piece was inside the valve train but caused no problems. The o-ring was replaced and no further problems.
Well that's good news. I think the others should be ok too. As long as the engine didn't overheat or ran with no oil, there shouldn't be any damage. When my head gasket went in my XTZ, the motor overheated and definitely cause some kind of damage. Even after the gasket was replaced, it never ran as good again. I think as long as its not the same seal leaking on everyone's unit that there is no run of bad gaskets or anything like there was on the Prowler. Probably just some assembly issues like yours Tiki................
 

·
Registered
Joined
·
8,623 Posts
Sounds like they need to go talk to the engine plant folks about if you really want to stay employed ya might best step up the quality control.
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #17 ·
Today the dealer looked at it quick and he said that it's probably the valve cover o ring should know tomorrow
 
1 - 20 of 37 Posts
Top