Wildcat Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey everyone
I have a 2013 wildcat 1000x
So I just purchased it and have had to do some repairs on it
After getting it running finally
I noticed at around 20 mph it starts bogging down really bad and won’t pick up any speed
I’ve changed the tps and it’s functioning properly
1 no throttle 100 full throttle
I’ve drained the tank and put new fuel in it with some Techron fuel treatment
But it won’t idle long enough to really run the gas
Has anyone had this issue and if so any suggestions on how to get it fixed ?
 

·
Administrator
Joined
·
27,869 Posts
Welcome Troublemaker. Members will probably need more information. How long did it sit around? Have you checked out the fuel pump and injectors? Once you get it to idle and run, throw on a new belt to start eliminating problems if you still can't get past 20.
 

·
Premium Member
Joined
·
2,485 Posts
I would do a compression test. You'll just chase your tail if you don't confirm that the basic engine is sound.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Welcome Troublemaker. Members will probably need more information. How long did it sit around? Have you checked out the fuel pump and injectors? Once you get it to idle and run, throw on a new belt to start eliminating problems if you still can't get past 20.
Well it sat around for about 2 years
The pump works and the injectors spray but at idle I’m only getting 25 psi fuel pressure and manual calls for 46 I believe... I’ve drained the tank and put new fuel but I feel it’s either water in the fuel from before or the fuel pressure what do you think
 

·
Administrator
Joined
·
27,869 Posts
Well it sat around for about 2 years
The pump works and the injectors spray but at idle I’m only getting 25 psi fuel pressure and manual calls for 46 I believe... I’ve drained the tank and put new fuel but I feel it’s either water in the fuel from before or the fuel pressure what do you think
I would clean the entire system, injectors, pump, tank (again). 2 years is kind of long, and gas will turn to varnish. You're getting something, just not full. At the very least, it couldn't hurt.
 

·
Registered
Joined
·
27 Posts
Hey everyone
I have a 2013 wildcat 1000x
So I just purchased it and have had to do some repairs on it
After getting it running finally
I noticed at around 20 mph it starts bogging down really bad and won’t pick up any speed
I’ve changed the tps and it’s functioning properly
1 no throttle 100 full throttle
I’ve drained the tank and put new fuel in it with some Techron fuel treatment
But it won’t idle long enough to really run the gas
Has anyone had this issue and if so any suggestions on how to get it fixed ?
Are you getting any error codes, I had a AC that was really sluggish just off idle, found the spark arrestor was so plugged it was restricting exhaust flow creating terrible performance issues
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Are you getting any error codes, I had a AC that was really sluggish just off idle, found the spark arrestor was so plugged it was restricting exhaust flow creating terrible performance issues
I originally had a PO122 but cleared that up
And I have a stage 5 trinity dual exhaust brand new
 
1 - 7 of 7 Posts
Top