Wildcat Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
1,535 Posts
Discussion Starter · #1 ·
Anybody had antifreeze pushing out of the overflow? Son rode his quite a bit today and we noticed liquid spots and wet drops on the right rear trailing arm. Turns out the overflow tube is zip tied just above it on the back fire wall. Had some fluid in it and was wet at the end. Doesn't appear to have a catch can, just vents off. Don't know if it is just over full, has a week cap or its a problem. We will keep an eye on it.
 

·
Registered
Joined
·
320 Posts
Both of my cats have done this after most rides. If you pay attention to the fans they run most of the time our motor is on which tells me they're running warm. I keep checking the fluid and mines been good so far 17 hours on one 12 on the other.
 

·
Registered
Joined
·
508 Posts
Im sure they fill the cooling system full when new so when you ride it and it heats up the fluid expands and runs out the overflow. Probably nothing to worry about.
 
  • Like
Reactions: pawnman

·
Registered
Joined
·
43 Posts
Anybody had antifreeze pushing out of the overflow? Son rode his quite a bit today and we noticed liquid spots and wet drops on the right rear trailing arm. Turns out the overflow tube is zip tied just above it on the back fire wall. Had some fluid in it and was wet at the end. Doesn't appear to have a catch can, just vents off. Don't know if it is just over full, has a week cap or its a problem. We will keep an eye on it.
Noticed same thing. There are two hoses, one coolant one gas vent. Seems my gas vent hose was pulled down with the highest point not much than the top of the tank. Pulled it up and reziptied and much less was venting. Did have some coolant vent on first few rides
 

·
Registered
Joined
·
1,535 Posts
Discussion Starter · #8 ·
My 500 wheeler is the same way. No overflow tank and it does vent off on a regular basis when it gets hot.
 

·
Registered
Joined
·
8,623 Posts
So it is filling the res totally and overflowing out the res? Thats not optimum, sounds like they didn't make the res large enough. It will of course move coolant to the res when the coolant expands when heated, but it will then draw it back into the system when it cools down and it cannot draw it back if it goes to the ground.
 

·
Registered
Joined
·
8,623 Posts
Possibly when they fill it up some extra makes its way to the res and they don't bother emptying it. If thats the case you will have some go out the overflow early on when the coolant that truly belongs there shows up as it is brought up to operating temp but then it should not happen anymore.
 

·
Registered
Joined
·
1,535 Posts
Discussion Starter · #17 ·
I had not removed the cover over the radiator so I assumed since it was overflowing there was no resevoir. As Tx said, it shouldn't push out more than it can contain. I will check the tank to see if it is above a full cold line. I know for sure my 500 does not have a tank, assumed the WC was probably the same way.
Copper, Where can we get a copy of the parts breakdown for the WC? Have not found one online yet.
 

·
Registered
Joined
·
2,100 Posts
Gotcha...even the XTZ1000 did it too
Mine did too. And then blew the head gasket. LOL! Had to get rid of it because it never ran the same after that. I know they all do it though. That's why I never really worried about mine until failure. I think that system could get a simple tweak to stop the leaking. Obviously not too high on their list since its been the same for 4 years................
 

·
Registered
Joined
·
218 Posts
Dents right there were problems on the prowler cooling. I think I remember the radiator cap being a problem. It was to low of PSI. Some changed it and all was good.
 

·
Registered
Joined
·
195 Posts
just noticed antifreeze leaking out of the tube on the ground as well
 
1 - 20 of 22 Posts
Top