Wildcat Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1,694 Posts
Discussion Starter · #1 ·
17 miles, i have noticed trying to put it in low, it is not engaging, indicator shows its in low , i am having to give a tap on the throttle and then it will slip on into low gear.
anyone else notice this?

seems difficult to move out of park on level surface.
 

·
Premium Member
Joined
·
576 Posts
pawn, most units will need a lil tap of throttle to engage. its all in where the gears are at the time of engagement. unless your shifter is out of adjustment sounds like its normal..
 

·
Registered
Joined
·
396 Posts
My Honda Pilot use to do the same thing and would need a blip of the throttle to get into gear
 

·
Registered
Joined
·
1,311 Posts
FWIW, my rzr s does it sometimes. The gears in these trannys don't have sincros or anything, so the gears need to be aligned to get it where you want. That's where the throttle blip comes in.
 

·
Registered
Joined
·
545 Posts
Both mine do it ,it actually will pop out of gear,dealer can fix it ,I talked to them while taking delivery of the 2nd bike,he said take the center console lot and there is an adjustment by the shifter.
 

·
Registered
Joined
·
1,311 Posts
Is it just me, or is it stupid that all the way forward is low gear instead of high? I'm thinking some sort of shift lockout is in order there so that you can slam it forward and it stops at high. From there, a lever on the shifter needs to be pulled to get into low.if something like that isn't available if/when I get mine I'll be devising a contraption of my own.
 

·
Registered
Joined
·
329 Posts
I would much prefer to have High all the way forward and low first out of neutral. Most of my trail riding will be done in low and with the poor turning radius there will be a lot of reverse/low shifting. Glad to hear that there is an adjustment, I'll have the dealer look at it when it's in for first service.

Dwight
 
1 - 12 of 12 Posts
Top