Wildcat Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So pulled the trigger on a new 15 sport xt on Saturday. Been so cold didn't get a lot of ride time this weekend, but today it got up to 48 so when I got home from work went for a ride, has 25 miles on it now. But now it seem like the clutch is staying engaged or if there is a clutch brake it isn't working because it shifts hard and hasn't before, the 4 times I have driven it. If i shut it off and start it I can shift like a breeze, put it in neutral and rev it up a little and it doesn't want to shift. I was also wondering if there is a spot where you can check the recalls that are out on it? Thanks in advance.
 

·
Premium Member
Joined
·
1,670 Posts
Sounds like the clutch isn't disengaging, that was a problem with them. Is it a new to you or a new dealer leftover? Talk to your dealer with your vin number to see if any of the updates or recalls have been done. 1/2" upper front a arm bolts, firewall recall, primary clutch. Those are the ones I can remember.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
New holdover, nice rebate and 2 year warranty, pretty pumped and it even fits in our little toyhauler. I will have to let them know just a little ways away.
 

·
Administrator
Joined
·
27,697 Posts
Welcome dragman1, congrats. I always recommend harnesses and a harness bar to all members. Safety first, fluff later.
 

·
Registered
Joined
·
677 Posts
My primary did the same thing. Good till about 300kms, then hard shifting. I think the '14's were warranty/update, '15's were case by case with AC. They did mine with uncalibrated assy, change over your weights etc.. Sooner you take it in the better for coverage I think. Odd guy cleaned theirs up and had luck, mine was no go. Get it addressed right away with low miles and should be taken care of for you.
 
1 - 5 of 5 Posts
Top