Wildcat Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
320 Posts
Discussion Starter · #1 ·
Well we went to Lake Havasu City, AZ this weekend and did a 78 Mile poker run through the desert of Parker. It was definitly a great ride with great weather. After all of the talk of the stock tires being nothing but crap I was pretty worried about the two cat's making it without a flat but decided to wing it. Well when we got to card stop 3 about 45 miles in I noticed a small oil spot about 6 inches in diameter underneath the engine on the skid plate. I figured well maybe it's just a little bit from changing the oil that was left on the frame or something that I missed, Eventhough I had the skid plate off to change the oil. I checked the filter, drain plug, and oil level and all were good. I continued the ride to the end and found a much larger pool of oil covering much of the skid plate now. Oil level still seemed to be ok. I stopped by my dealer on the way back to the house in Havasu and was informed that they had already dealt with a similar problem where it was a loose bolt on the pan and it was necessary to remove the motor in order to tighten it. Seemed kinda fishy, but nonetheless I cleaned it up at the house (minus the oil leak), and dropped it back off at the dealer to have them look at it. I looked at it thoroughly before we returned it to them and saw no signs of loose bolts, torn gaskests or anything. The only unusual thing I noticed was what looked to be gasket sealer/material from the right side of the pan and none on the left.

The second problem was that the front radiator was leaking coolant out of it from the hose and clamp on the right side. Both of my cats were leaking quite a bit form here. Simple tighten up and we shall see how they do.
 

·
Registered
Joined
·
90 Posts
I think they all leak coolant from there. First run issues I spose. All i ask is that wc reads this stuff :fingersx:
 

·
Registered
Joined
·
2,100 Posts
All these oil leaks are pretty puzzling considering that this is not a new motor for them. With ramped up production, they could be getting their seals and gaskets from a new supplier though. That's what happened with the XTZ head gaskets. Hopefully its all just minor stuff. Just sucks when its sitting at the dealer and not being driven.............
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #4 ·
True I was pissed I couldn't drive it yesterday and it sits in the rain at the dealer too!!!! Well hopefully it's an easy fix. I had the coolant burp out earlier H2S but this is a different location and it was actually out of the hose on the right side of the rig. You could see it come out from under the clamp. tightened and so far no problems.
 

·
Registered
Joined
·
6 Posts
I've found it a good idea to check all hose clamps and pan bolts/screws regularly especially while it's new. That's not uncommon to have gaskets and hoses compress a little when new.
 
1 - 6 of 6 Posts
Top