Wildcat Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Well I installed a SATV LT kit on ny trail and loved it....until now. Took her to coos bay for some dunes runs and popped the LR axle out twice now and the LF out and chewed up the front diff. I know there are "updated c-clips" for the rear. Curious if anyone had front issues. Replaced the LF with a stock sport axle and have had no other issues. Wish the rhino axles had the OE lock style c-clip.


Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
146 Posts
Yep! LF axle stub has no threads left on it, sheared the cotter pin and pushed the castle nut completely off of the axle. Luckily the tire did not come off before we stopped. No issues with c-clips though.
 

·
Registered
Joined
·
308 Posts
Yes, I experienced the same thing Toren. I got the larger clips for the rear from SuperATV (still not sure why they don't just included them with kit...)
There was a second problem though, and I'm pretty sure this is why my front popped out....
(this is right from SATV support) Seems in some instances, during transportation (by air frieght) all the air can be forced out of the boots, and they don't recover on their own. If you take an axle, pull on / extend the end, and it just springs right back... might be your problem. I took the small clip off each boot, "burped" the air back in (I made sure to extend each one, while I had a small screwdriver prying the rubber open, then pull the screwdriver out while it was extended, sealing as much air as I could in there)
I used a genuine redneck clip on each boot (heavy zip tie lol) and have not had any trouble since. Probably gone about 500km since, in both winter and warm weather.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Yes, I experienced the same thing Toren. I got the larger clips for the rear from SuperATV (still not sure why they don't just included them with kit...)
There was a second problem though, and I'm pretty sure this is why my front popped out....
(this is right from SATV support) Seems in some instances, during transportation (by air frieght) all the air can be forced out of the boots, and they don't recover on their own. If you take an axle, pull on / extend the end, and it just springs right back... might be your problem. I took the small clip off each boot, "burped" the air back in (I made sure to extend each one, while I had a small screwdriver prying the rubber open, then pull the screwdriver out while it was extended, sealing as much air as I could in there)
I used a genuine redneck clip on each boot (heavy zip tie lol) and have not had any trouble since. Probably gone about 500km since, in both winter and warm weather.
Intresting. I noticed today when I racked it to remove my firewall for the recall that LR axle that had popped out had the boot sucked in. That axle popped out 2x. Ill try this with the LR. The RF axle needs to be replaced tho.


Sent from my SM-G950U using Tapatalk
 

·
Vendor
Joined
·
169 Posts
Good catch man. Conor is right. The air pressure from shipping will force air out sometimes. Its sealed pretty good and won't let air back in so it creates a vacuum and won't let the CV extend out all the way during travel. If it looks sucked in, or won't extend out and stay out, it probably needs "burped." Just let a little air in there.
 

·
Registered
Joined
·
74 Posts
My Left Rear popped out and I couldn't find anything on here about it.. Now I see a few! But folks, "do you believe the airplane explanation" about the air pressure? I don't as I am an engineer. So people, what is the real cause?

Denny
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
My Left Rear popped out and I couldn't find anything on here about it.. Now I see a few! But folks, "do you believe the airplane explanation" about the air pressure? I don't as I am an engineer. So people, what is the real cause?

Denny
Started thinking about this today annnnddd....


Yaaaahhhh....so not to rain on SATVs parade especially since I just filed my warranty claim, but I would agree that the air/suction explanation is kinda far fetched. Heres why....

So my LR axle popped out on a trail run at the dunes. When it did the axle went backwards into the swaybar link bolt and tore the boot. So back at camp pulled the axle and replaced the boot and installed clean grease. Well heres the rub...I had it all apart and there was deffinetly air in it when it went back in, but 5miles later she popped out again.

So fast forward to my above comment. Today I used a screw driver and "burped" the boot. For chits I deove it while on the rack at full droop....guess what. It pushed the air out its self and once again sucked the boot in. So the question is how to fix this. After the second time of the axle popping out we made some limiter straps up and it didnt happen again. They were temporary tho and only lasted the trip. Would like to trust this thing in trails and dunes again.

Sent from my SM-G950U using Tapatalk
 

·
Vendor
Joined
·
169 Posts
Started thinking about this today annnnddd....


Yaaaahhhh....so not to rain on SATVs parade especially since I just filed my warranty claim, but I would agree that the air/suction explanation is kinda far fetched. Heres why....

So my LR axle popped out on a trail run at the dunes. When it did the axle went backwards into the swaybar link bolt and tore the boot. So back at camp pulled the axle and replaced the boot and installed clean grease. Well heres the rub...I had it all apart and there was deffinetly air in it when it went back in, but 5miles later she popped out again.

So fast forward to my above comment. Today I used a screw driver and "burped" the boot. For chits I deove it while on the rack at full droop....guess what. It pushed the air out its self and once again sucked the boot in. So the question is how to fix this. After the second time of the axle popping out we made some limiter straps up and it didnt happen again. They were temporary tho and only lasted the trip. Would like to trust this thing in trails and dunes again.
Did the axle pop out after letting the air in, or did the boot just fold in? It may have sufficient pressure in there now, and not have that vacuum issue that won't allow it to fully extend. I'm not saying the airplane scenario is the reason, but that's been tossed around as a plausable reason that they could have a vacuum, as they're traveling in an unpressurized FedEx or UPS cargo plane. I know it may sound silly, Lol, but its a real thing. Letting air in there always seems to fix the vacuum issue. I can get fully extended measurements to match them up if you want. It'll be the same as an OEM Sport axle.

Another thing to check for is leaking shocks. We have a shop cat that had the same issue, but it ended up having a leaky shock that let the arm drop too far and popped the axle out.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
Did the axle pop out after letting the air in, or did the boot just fold in? It may have sufficient pressure in there now, and not have that vacuum issue that won't allow it to fully extend. I'm not saying the airplane scenario is the reason, but that's been tossed around as a plausable reason that they could have a vacuum, as they're traveling in an unpressurized FedEx or UPS cargo plane. I know it may sound silly, Lol, but its a real thing. Letting air in there always seems to fix the vacuum issue. I can get fully extended measurements to match them up if you want. It'll be the same as an OEM Sport axle.

Another thing to check for is leaking shocks. We have a shop cat that had the same issue, but it ended up having a leaky shock that let the arm drop too far and popped the axle out.
Yah it had plenty of air when it popped out the second time as I had to reboot the inner joint. The front i could see as the c clip is tiny. The rears tho seem like they shouldnt but I havent seen the bigger clips either. Still love this kit over all. Made it into a new machine. Hopefully get warranty parts soon to get back up and riding.

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
146 Posts
Good catch man. Conor is right. The air pressure from shipping will force air out sometimes. Its sealed pretty good and won't let air back in so it creates a vacuum and won't let the CV extend out all the way during travel. If it looks sucked in, or won't extend out and stay out, it probably needs "burped." Just let a little air in there.
I am calling BS. Rhino axles have proven to be junk with me. A rubber boot will not pull an axle stub out of a differential if the axle is made right. I am on 14 axles now on 2 buggies with roughly 1000 between them. BUT, SATV keeps letting me buy them while their “tech” department looks into the issue. Don’t do it. SATV does not stand behind their axles. Their lift kits and long travel kits are spot on except for the Rhino Axle crap.
 

·
Registered
Joined
·
146 Posts
Nope, pure BS. A rubber boot will not dislodge an axle that basically takes a slide hammer to remove. Poor excuses from SATV.

My Left Rear popped out and I couldn't find anything on here about it.. Now I see a few! But folks, "do you believe the airplane explanation" about the air pressure? I don't as I am an engineer. So people, what is the real cause?

Denny
 

·
Registered
Joined
·
11 Posts
Discussion Starter #12
I am calling BS. Rhino axles have proven to be junk with me. A rubber boot will not pull an axle stub out of a differential if the axle is made right. I am on 14 axles now on 2 buggies with roughly 1000 between them. BUT, SATV keeps letting me buy them while their “tech” department looks into the issue. Don’t do it. SATV does not stand behind their axles. Their lift kits and long travel kits are spot on except for the Rhino Axle crap.
Yep!!

Found all this out this morning ^^

"Well the LR axle popping out 3 times isnt a breakage, so I can sell you a new inner joint."

Can you just send me a new c-clip to try first?

"No we dont sell the clips or supply them anymore. You have to buy the joint."


Guess the turbo kit i was gonna order aint happening now. Back to stock axles I guess.

Sent from my SM-G950U using Tapatalk
 

·
Vendor
Joined
·
169 Posts
Its no prob to send the clips. It was probably a newbie that isn't familiar with the Cat. Arctic Cat has their clip locking design patented, so we try to cover that by adding the bigger clips. You may not have the newest gen clip. The Cats we have in the shop have all been great with the new clips. We haven't been able to recreate it since. One of the guys beats the hell out of his every weekend at all the big IN, KY, and TN parks in the area, and still can't recreate it with the new clips. Hopefully that's it. 9 out of 10 times its the fix. If not, the OE sport axle has their patented clip design and it may work better. If you guys want to PM me your info, I'll fire some out for you.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #14
Its no prob to send the clips. It was probably a newbie that isn't familiar with the Cat. Arctic Cat has their clip locking design patented, so we try to cover that by adding the bigger clips. You may not have the newest gen clip. The Cats we have in the shop have all been great with the new clips. We haven't been able to recreate it since. One of the guys beats the hell out of his every weekend at all the big IN, KY, and TN parks in the area, and still can't recreate it with the new clips. Hopefully that's it. 9 out of 10 times its the fix. If not, the OE sport axle has their patented clip design and it may work better. If you guys want to PM me your info, I'll fire some out for you.
The guy I talked to was very adamant about the clips not being available and that he couldnt help me out at all even know this kit is a month old. He said all have been updated and that Id have to buy a joint. Not gonna lie not too happy at this moment with the decision to buy this kit mostly based on the CS side. The arms are awesome and it made my machine feel like new but the reliability of the axles is deffinetly in question. Posted my issues on the FB wildcat trail page and within 10mins had 4 guys with the same issue, 2 of which said they got refunds for the 4 rhino axles and were informed to buy stock sport axles. I dont really care what thensolution is I just want to ride!!

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
308 Posts
its an interesting note here, that SATV does not make the axles (as they do the rest of the kit) Makes me wonder if people who have Sports, and "upgrade" to Rhino axles, have this problem too?
 

·
Premium Member
Joined
·
1,579 Posts
I'm questioning their comment about a leaky shock causing an axle to come out. Full droop on a shock isn't governed by fluid or nitrogen.
 

·
Vendor
Joined
·
169 Posts
Ya caught that did ya...

Sent from my SM-G950U using Tapatalk
Lol! Not my machine, but its legit. Still here at the shop. Same one we designed the kit for. Whatever it was...the shock was leaking and it was also overextended, letting the trailing arm drop way too low at full drop. Coincidence? I don't know, but my buddy just got new shocks and hasn't had an axle problem since.
 

·
Registered
Joined
·
401 Posts
I have a sport ltd that i installed the satv high clearance arms on along with rhino axles. Stock arms had egged out.

No axle issues here but i don't have more than a100 miles on it since upgrading.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #20
I have a sport ltd that i installed the satv high clearance arms on along with rhino axles. Stock arms had egged out.

No axle issues here but i don't have more than a100 miles on it since upgrading.
Thats about what I have on this kit. Its intresting and very apparent that social media has a stronghold on CS. Calling tech support resulted in a guy that really didnt want to do anything help wise....then post here and a rep for the forum fires out the "non in stock c-clips that they cant supply". Lol.

Sent from my SM-G950U using Tapatalk
 
1 - 20 of 23 Posts
Top