Wildcat Forum banner

1 - 20 of 90 Posts

·
Registered
Joined
·
4,508 Posts
Discussion Starter #1
I've noticed my heat shield has a rattle at 15 to 20 MPH. It doesn't do it every time at that speed. I didn't find any bolts loose. Has anyone noticed this? Any ideas ?
 

·
Registered
Joined
·
437 Posts
Yep. Had the same problem. Couldn't find anything loose. Removed the rear cover that surrounds the exhaust outlet and tightened up the 3 screws holding in the spark arrestor. Worked great for a while but started rattling again. Tack welded the 3 screws and it was good until the rest of the muffler fell apart around the 800 mile mark.
 

·
Registered
Joined
·
4,508 Posts
Discussion Starter #3
Would it hurt to take it off? I've noticed the RZR 800 doesn't even have on.
 

·
Registered
Joined
·
332 Posts
Would it hurt to take it off? I've noticed the RZR 800 doesn't even have on.
_________

Don't take that heat shield off!!!

It needs to be secured and bolted/welded tight! .... otherwise you run a decent risk of melting down your exhaust can and whatever is next to it..... In my case it was my bed and taillights that cooked. SO MANY of these exhausts have burnt up and a few machines have burned down due to this loose triangular heat shield. You are going to want to fix that rattle ASAP or you can plan on replacing your entire exhaust soon at best! ... at worst you will cause your machine to burn down. That much heat next to the plastic exhaust tank gets a little scary..... I consider myself lucky only having to replace entire exhaust and entire rear light assembly, and melting my bed....

Here is a little more info on that heat shield situation. http://www.wildcatforums.net/forum/issues-resolutions/4818-red-hot-exhaust-4.html


 

·
Registered
Joined
·
4,508 Posts
Discussion Starter #5
Im not going go take it off. I may put some worm clamps around it.
 

·
Registered
Joined
·
485 Posts
Mine started rattling a little, gonna try to tighten it up
 

·
Premium Member
Joined
·
361 Posts
My sounds like a tuning fork at various engine speeds ...... Driving me crazy. I could only find 2 bolts holding it in place .... I'll have to look a little closer. A person just needs to add a little mass, or a stiffener to this shield to change the resonance point.
 

·
Registered
Joined
·
429 Posts
Yep. Had the same problem. Couldn't find anything loose. Removed the rear cover that surrounds the exhaust outlet and tightened up the 3 screws holding in the spark arrestor. Worked great for a while but started rattling again. Tack welded the 3 screws and it was good until the rest of the muffler fell apart around the 800 mile mark.
this is the 1000 wildcat not the 700?????
 

·
Registered
Joined
·
4,508 Posts
Discussion Starter #10
image.jpg

I found the cause for the rattling. The hole in the heat shield for the O2 sensor is rattling on it. I got a 12 inch worm clamp. The other fix is You could make the hole bigger if you wanted too. The simple fix is a worm clamp.
 

·
Registered
Joined
·
597 Posts
Hey TN680....now that you have had this on for a few months I was curious if the rattle is still gone? My new machine is doing the same thing.
 

·
Registered
Joined
·
4,508 Posts
Discussion Starter #14 (Edited)
It's GONE!!!! Once I put the clamp, I didn't want to bend the heat shield, so I didn't tighten it all the way down. The rattling came back, so tighten the clamp until I coundn't anymore. The heat shield didn't bend that much. The noise is gone!!!!! The ride is so much better. I hated that noise, my wife would be like "what is that"? LOL "is this thing junk" NO honey!! LOL So tighten the hell out of it!!!
 

·
Registered
Joined
·
597 Posts
Thanks....I will take care of it tomorrow after Hurricane Arthur Blows through! LOL
 

·
Registered
Joined
·
4,508 Posts
Discussion Starter #17
12 inch, I used my dremel to cut the excess off. I got stainless too.
 

·
Registered
Joined
·
37 Posts
THANK YOU!!!!!! TN6680 you saved the day with the pics. I am still on the 10 hour break in period 5.6 hours, 54.8 miles, but who's counting ;) and i was thinking i was going to have to tear everything out at first service to find the rattle. 10 min search, 5 minute repair, back riding and enjoying the new sport!
 

·
Registered
Joined
·
461 Posts
View attachment 17101

I found the cause for the rattling. The hole in the heat shield for the O2 sensor is rattling on it. I got a 12 inch worm clamp. The other fix is You could make the hole bigger if you wanted too. The simple fix is a worm clamp.

I did this and it worked great. A 4" clamp works fine.
 

·
Registered
Joined
·
3,231 Posts
Yup. Work clamp is the fix
 
1 - 20 of 90 Posts
Top