Wildcat Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Somebody with some experience please help me. So when I first got this machine about 2 months ago she was fast as can be, 75-80 no problem around 7500 rpm’s, been noticing lately she is down on power and only revs to about 6300, I checked fuel pressure and noticed it was down and narrowed it down to the regulator so I replaced it and now it’s back to 43 where it should be but didn’t help my problem, installed a new belt thinking it would help but no sadly. Could it still be a fueling issue or something else I’m looking over? Something with my clutch? Tps is 100 percent. I’m at wits end.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I checked tps and it’s at 100 percent, Im not sure what could drain power like that. I talked to a tech and he said sometimes the springs gets worn in the primary around 2k miles.
 

·
Registered
Joined
·
8 Posts
never knew that, my wildcat is coming pretty close to the 2k mark so I guess ill watch out for that, maybe you should get aftermarket or upgraded sprigs instead of the stock ones, people say they're better, never tried that tho maybe you should
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Well boys… it ain’t good…. I kept digging and took the whole clutch cover and all off today, the crank bearing on the clutch side is broken and I assume getting tight so won’t allow the motor to rev out, explains why the motor got so dang noisey.. I knew in my gut that’s what it was.
 
1 - 10 of 10 Posts
Top