Wildcat Forum banner

21 - 40 of 54 Posts

·
Registered
Joined
·
2,912 Posts
Thanks for the heads up...I will watch it close for sure. It's easy enough to pull the cover and check. This should be one of those learn from others moments I guess.

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #22 ·
Did arctic cat replace your motor? what is the fix? I dont want to fix it and have to worry about this all the time
 

·
Registered
Joined
·
5,404 Posts
AC replaced my motor yes, because the problems started when I was still in warranty. I cannot guarantee they will do the same for you if you are out of warranty. I had it in the dealer when the problems started. Good luck and let us know how it turns out.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #24 ·
FYI, artic cat warranty covered it, giving me a short block. Just letting everybody know, they have been very helpful with me. They stated that people have changed spark plugs to correct this problem, unoffical response. Just have to hope for the best in the future.
 

·
Administrator
Joined
·
27,822 Posts
FYI, artic cat warranty covered it, giving me a short block. Just letting everybody know, they have been very helpful with me. They stated that people have changed spark plugs to correct this problem, unoffical response. Just have to hope for the best in the future.
Congrats!!!!!
 

·
Registered
Joined
·
5,404 Posts
Spark plugs? I like to hear why they thought that was the cause. Glad they took care of you
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #27 ·
Just some more info to pass, after short block was replaced, I had 32 miles on the machine. Guess what? Broken starter gears, starter, crank sensor and had to be towed back in. I have contacted ARCTIC CAT, waiting on a reply. I see that a lot of X owners are having the same problem, does anybody have a fix? I also have 2013 wildcat 1000 with 2700 miles and no starter issues. The problem has to be in the cam,timing and compression. I suggest that everybody contact AC, and let them know just how many customers are having this problem, maybe we will get some answers. I will be selling this 2014X, when it is fixed, unless they come up with a better repair than just changing starter and gears.
 

·
Registered
Joined
·
2,912 Posts
Man I hate to hear your problems. I have 1400 trouble free miles and my buddy has 1k miles on his. I don't see how it can be so hit or miss.

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
5,404 Posts
When you replaced your short block, did they replace everything? I guess what I am asking is if the short block was put in as a complete motor? Clutches, intake, and all?
 

·
Registered
Joined
·
4,094 Posts
I bet the inner race of the Torrington bearing has marginal quality and is soft enough to get "micro dings" when the machine back fires during starting. (Or some of the Torrington segments get reshaped)

The instantaneous forces when a cylinder tries to fire backwards (with the Torrington engaged) have gotta be huge.

Of course, the 2015 models have a cleaner fueling profile and don't have the "lumpy" over rich idle problem like the early X models ... maybe if the fueling were cleaner the Torrington would never get damaged in the first place. If this is the case then AC will probably just deal with the problem one by one and wait for the old X's to become garage queens. :rolleyes:
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #31 ·
Just the short block, starter and gears. They would not replace flywheel and one way clutch, I tried to get them to do that. Hopefully they will do it this time.
 

·
Registered
Joined
·
2,912 Posts
You need to replace everything! They are fixing what is broke and not what is causing it to break.

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
5,404 Posts
What thunder said. I can't believe they removed the old parts and put them on the new.
 

·
Registered
Joined
·
5,404 Posts
Did the new motor come with a new decompression valve? If so, that would eliminate that as the problem.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #35 ·
no decompression valve on this motor, they said they are replacing flywheel and one way clutch. not sure if this will correct the problem. Time will tell....
 

·
Registered
Joined
·
5,404 Posts
There is a very cheap wave washer back there too, I would try really hard to get them to replace that too. It is cheap and while they are in there, might as well. Please let us know what happens with this. Thanks.
 

·
Registered
Joined
·
682 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #39 ·
update, just talked to Arctic Cat consumer advocate, they are going to change the one way clutch this time and all the other parts that are broken. The AC tech says that it should have been changed the first time the gears broke. He also looking onto the 2016 X using a different starter and gears. My question was, what is causing these breakages?, they are not sure if its the one way clutch..... See what happens when I get it back. I will update the final outcome, in case somebody else runs into the same break down...
 

·
Registered
Joined
·
5,404 Posts
I would ask about that $2 wave washer while they are in there too. Quite a few have had this issue with no real solution yet so please report back. Thanks
 
21 - 40 of 54 Posts
Top